MetaTrader 4 builds older than 416 no longer supported

From today, June 1st 2012, the support of client terminals that are older than build 416 will no longer be provided. This means that the connection to the server will be blocked by MetaQuotes.

You can check your version by clicking on HELP > ABOUT in your MetaTrader. You are welcome to download the latest build of MetaTrader 4 on https://www.finfx.fi/en/downloads .

In case your need further assistance, our Customer Service will be glad to help you.